use strict;
my $str = 'Length 7 or 9 First character must be a letter a-z or A-Z if number of characters are 7 The remaining 6 must be numeric 0-9 example
a555444
B999999
Third character must be a letter a-z or A-Z if number of characters are 9 The remaining 8 must be numeric 0-9
example
12B456789
16K456745
';
my $regex = qr/^([A-Za-z][0-9]{6}|[0-9]{2}[A-Za-z][0-9]{6})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}