re = /^([A-Za-z][0-9]{6}|[0-9]{2}[A-Za-z][0-9]{6})$/m
str = 'Length 7 or 9 First character must be a letter a-z or A-Z if number of characters are 7 The remaining 6 must be numeric 0-9 example
a555444
B999999
Third character must be a letter a-z or A-Z if number of characters are 9 The remaining 8 must be numeric 0-9
example
12B456789
16K456745
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end