package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Za-z][0-9]{6}|[0-9]{2}[A-Za-z][0-9]{6})$`)
var str = `Length 7 or 9 First character must be a letter a-z or A-Z if number of characters are 7 The remaining 6 must be numeric 0-9 example
a555444
B999999
Third character must be a letter a-z or A-Z if number of characters are 9 The remaining 8 must be numeric 0-9
example
12B456789
16K456745
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}