import Foundation
let pattern = #"^([A-Za-z][0-9]{6}|[0-9]{2}[A-Za-z][0-9]{6})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Length 7 or 9 First character must be a letter a-z or A-Z if number of characters are 7 The remaining 6 must be numeric 0-9 example
a555444
B999999
Third character must be a letter a-z or A-Z if number of characters are 9 The remaining 8 must be numeric 0-9
example
12B456789
16K456745
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)