#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)tec.world[^=]*=([^H]*)HOST\s*=\s([^\)]*)\s*\)"
Local $sString = "A01.WORLD=" & @CRLF & _
" (DESCRIPTION =" & @CRLF & _
" (SDU = 32768)" & @CRLF & _
" (ADDRESS_LIST =" & @CRLF & _
" (ADDRESS =" & @CRLF & _
" (COMMUNITY = SAP.WORLD)" & @CRLF & _
" (PROTOCOL = TCP)" & @CRLF & _
" (HOST = columbus)" & @CRLF & _
" (PORT = 1529)" & @CRLF & _
" )" & @CRLF & _
" (CONNECT_DATA =" & @CRLF & _
" (SID = A01)" & @CRLF & _
" (GLOBAL_NAME = A01.WORLD)" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
"" & @CRLF & _
"TEC.WORLD=" & @CRLF & _
" (DESCRIPTION =" & @CRLF & _
" (ADDRESS_LIST =" & @CRLF & _
" (ADDRESS =" & @CRLF & _
" (COMMUNITY = TEC.WORLD)" & @CRLF & _
" (PROTOCOL = TCP)" & @CRLF & _
" (HOST = columbus)" & @CRLF & _
" (PORT = 1521)" & @CRLF & _
" )" & @CRLF & _
" )" & @CRLF & _
" (CONNECT_DATA =" & @CRLF & _
" (SID = TEC)" & @CRLF & _
" (GLOBAL_NAME = TEC.WORLD)" & @CRLF & _
" )" & @CRLF & _
")"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")