import re
regex = re.compile(r"tec.world[^=]*=([^H]*)HOST\s*=\s([^\)]*)\s*\)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("A01.WORLD=\n"
" (DESCRIPTION =\n"
" (SDU = 32768)\n"
" (ADDRESS_LIST =\n"
" (ADDRESS =\n"
" (COMMUNITY = SAP.WORLD)\n"
" (PROTOCOL = TCP)\n"
" (HOST = columbus)\n"
" (PORT = 1529)\n"
" )\n"
" (CONNECT_DATA =\n"
" (SID = A01)\n"
" (GLOBAL_NAME = A01.WORLD)\n"
" )\n"
" )\n\n"
"TEC.WORLD=\n"
" (DESCRIPTION =\n"
" (ADDRESS_LIST =\n"
" (ADDRESS =\n"
" (COMMUNITY = TEC.WORLD)\n"
" (PROTOCOL = TCP)\n"
" (HOST = columbus)\n"
" (PORT = 1521)\n"
" )\n"
" )\n"
" (CONNECT_DATA =\n"
" (SID = TEC)\n"
" (GLOBAL_NAME = TEC.WORLD)\n"
" )\n"
")")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")