import Foundation
let pattern = #"tec.world[^=]*=([^H]*)HOST\s*=\s([^\)]*)\s*\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
A01.WORLD=
  (DESCRIPTION =
    (SDU = 32768)
    (ADDRESS_LIST =
        (ADDRESS =
          (COMMUNITY = SAP.WORLD)
          (PROTOCOL = TCP)
          (HOST = columbus)
          (PORT = 1529)
       )
    (CONNECT_DATA =
       (SID = A01)
       (GLOBAL_NAME = A01.WORLD)
    )
  )
TEC.WORLD=
  (DESCRIPTION =
    (ADDRESS_LIST =
        (ADDRESS =
          (COMMUNITY = TEC.WORLD)
          (PROTOCOL = TCP)
          (HOST = columbus)
          (PORT = 1521)
        )
    )
    (CONNECT_DATA =
       (SID = TEC)
        (GLOBAL_NAME = TEC.WORLD)
        )
)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
    let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
    print(result)
} else {
    print("No matches were found.")
}