$re = '/tec.world[^=]*=([^H]*)HOST\s*=\s([^\)]*)\s*\)/im';
$str = 'A01.WORLD=
(DESCRIPTION =
(SDU = 32768)
(ADDRESS_LIST =
(ADDRESS =
(COMMUNITY = SAP.WORLD)
(PROTOCOL = TCP)
(HOST = columbus)
(PORT = 1529)
)
(CONNECT_DATA =
(SID = A01)
(GLOBAL_NAME = A01.WORLD)
)
)
TEC.WORLD=
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS =
(COMMUNITY = TEC.WORLD)
(PROTOCOL = TCP)
(HOST = columbus)
(PORT = 1521)
)
)
(CONNECT_DATA =
(SID = TEC)
(GLOBAL_NAME = TEC.WORLD)
)
)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);