using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"tec.world[^=]*=([^H]*)HOST\s*=\s([^\)]*)\s*\)";
string input = @"A01.WORLD=
(DESCRIPTION =
(SDU = 32768)
(ADDRESS_LIST =
(ADDRESS =
(COMMUNITY = SAP.WORLD)
(PROTOCOL = TCP)
(HOST = columbus)
(PORT = 1529)
)
(CONNECT_DATA =
(SID = A01)
(GLOBAL_NAME = A01.WORLD)
)
)
TEC.WORLD=
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS =
(COMMUNITY = TEC.WORLD)
(PROTOCOL = TCP)
(HOST = columbus)
(PORT = 1521)
)
)
(CONNECT_DATA =
(SID = TEC)
(GLOBAL_NAME = TEC.WORLD)
)
)";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}