package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)tec.world[^=]*=([^H]*)HOST\s*=\s([^\)]*)\s*\)`)
var str = `A01.WORLD=
(DESCRIPTION =
(SDU = 32768)
(ADDRESS_LIST =
(ADDRESS =
(COMMUNITY = SAP.WORLD)
(PROTOCOL = TCP)
(HOST = columbus)
(PORT = 1529)
)
(CONNECT_DATA =
(SID = A01)
(GLOBAL_NAME = A01.WORLD)
)
)
TEC.WORLD=
(DESCRIPTION =
(ADDRESS_LIST =
(ADDRESS =
(COMMUNITY = TEC.WORLD)
(PROTOCOL = TCP)
(HOST = columbus)
(PORT = 1521)
)
)
(CONNECT_DATA =
(SID = TEC)
(GLOBAL_NAME = TEC.WORLD)
)
)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}