#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:(?!#).*\R)+#"
Local $sString = "text1" & @CRLF & _
"text2" & @CRLF & _
"text3" & @CRLF & _
"text3" & @CRLF & _
"# text 5"
Local $sSubst = "#"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)