re = /^(?:(?!#).*\R)+#/m
str = 'text1
text2
text3
text3
# text 5'
subst = '#'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result