$re = '/^(?:(?!#).*\R)+#/m';
$str = 'text1
text2
text3
text3
# text 5';
$subst = "#";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;