const regex = /^(?:(?!#).*\R)+#/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?!#).*\\R)+#', 'gm')
const str = `text1
text2
text3
text3
# text 5`;
const subst = `#`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);