import Foundation
let pattern = ##"^(?:(?!#).*\R)+#"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
text1
text2
text3
text3
# text 5
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"#"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)