use strict;
my $str = 'text1
text2
text3
text3
# text 5';
my $regex = qr/^(?:(?!#).*\R)+#/mp;
my $subst = '#';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";