$re = '/([a-z])\1/mi';
$str = 'too many professionals
would turn into
tooo many professsionals';
$subst = "$1$1$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;