#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ".journal-bg {[^{]*(?<bc>background-color.*;)[^{]*}"
Local $sString = "sadf" & @CRLF & _
".journal-bg { " & @CRLF & _
"background-color: #112021; " & @CRLF & _
"background: #184E3B #154a47;" & @CRLF & _
"background: -moz-linear-gradient(top, #154a47 0%, #598238 100%);" & @CRLF & _
" background: -webkit-linear-gradient(top, #154a47 0%, #598238 100%);" & @CRLF & _
" background: linear-gradient(to bottom, #154a47 0%, #598238 100%);" & @CRLF & _
" filter: progid:DXImageTransform.Microsoft.gradient(startColorstr='#154a47', endColorstr='#598238', GradientType=0 );" & @CRLF & _
" border-bottom: 3px solid #F7EF8F;" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")