use strict;
my $str = 'sadf
.journal-bg {
background-color: #112021;
background: #184E3B #154a47;
background: -moz-linear-gradient(top, #154a47 0%, #598238 100%);
background: -webkit-linear-gradient(top, #154a47 0%, #598238 100%);
background: linear-gradient(to bottom, #154a47 0%, #598238 100%);
filter: progid:DXImageTransform.Microsoft.gradient(startColorstr=\'#154a47\', endColorstr=\'#598238\', GradientType=0 );
border-bottom: 3px solid #F7EF8F;
}';
my $regex = qr/.journal-bg {[^{]*(?<bc>background-color.*;)[^{]*}/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}