import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".journal-bg \\{[^\\{]*(?<bc>background-color.*;)[^\\{]*\\}";
final String string = "sadf\n"
+ ".journal-bg { \n"
+ "background-color: #112021; \n"
+ "background: #184E3B #154a47;\n"
+ "background: -moz-linear-gradient(top, #154a47 0%, #598238 100%);\n"
+ " background: -webkit-linear-gradient(top, #154a47 0%, #598238 100%);\n"
+ " background: linear-gradient(to bottom, #154a47 0%, #598238 100%);\n"
+ " filter: progid:DXImageTransform.Microsoft.gradient(startColorstr='#154a47', endColorstr='#598238', GradientType=0 );\n"
+ " border-bottom: 3px solid #F7EF8F;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}