re = /.journal-bg {[^{]*(?<bc>background-color.*;)[^{]*}/
str = 'sadf
.journal-bg {
background-color: #112021;
background: #184E3B #154a47;
background: -moz-linear-gradient(top, #154a47 0%, #598238 100%);
background: -webkit-linear-gradient(top, #154a47 0%, #598238 100%);
background: linear-gradient(to bottom, #154a47 0%, #598238 100%);
filter: progid:DXImageTransform.Microsoft.gradient(startColorstr=\'#154a47\', endColorstr=\'#598238\', GradientType=0 );
border-bottom: 3px solid #F7EF8F;
}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end