# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".journal-bg {[^{]*(?<bc>background-color.*;)[^{]*}"
test_str = ("sadf\n"
".journal-bg { \n"
"background-color: #112021; \n"
"background: #184E3B #154a47;\n"
"background: -moz-linear-gradient(top, #154a47 0%, #598238 100%);\n"
" background: -webkit-linear-gradient(top, #154a47 0%, #598238 100%);\n"
" background: linear-gradient(to bottom, #154a47 0%, #598238 100%);\n"
" filter: progid:DXImageTransform.Microsoft.gradient(startColorstr='#154a47', endColorstr='#598238', GradientType=0 );\n"
" border-bottom: 3px solid #F7EF8F;\n"
"}")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.