#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\d{4}\.\d{2}\.\d{2}\.\d{2}\.\d{2}\.\d{2}\.txt)$"
Local $sString = "" & @CRLF & _
"C:\BrowserAutomationStudio\apps\18.4.0>dir "C:\work\appslocal\logs\log\" /O:D /B " & @CRLF & _
"2017.05.14.08.56.42.txt" & @CRLF & _
"2017.05.15.08.24.52.txt" & @CRLF & _
"2017.05.15.23.56.03.txt" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")