$re = '/(\d{4}\.\d{2}\.\d{2}\.\d{2}\.\d{2}\.\d{2}\.txt)$/';
$str = '
C:\\BrowserAutomationStudio\\apps\\18.4.0>dir "C:\\work\\appslocal\\logs\\log\\" /O:D /B
2017.05.14.08.56.42.txt
2017.05.15.08.24.52.txt
2017.05.15.23.56.03.txt
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);