using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{4}\.\d{2}\.\d{2}\.\d{2}\.\d{2}\.\d{2}\.txt)$";
string input = @"
C:\BrowserAutomationStudio\apps\18.4.0>dir ""C:\work\appslocal\logs\log\"" /O:D /B
2017.05.14.08.56.42.txt
2017.05.15.08.24.52.txt
2017.05.15.23.56.03.txt
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}