// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\d{4}\.\d{2}\.\d{2}\.\d{2}\.\d{2}\.\d{2}\.txt)$").unwrap();
let string = "
C:\\BrowserAutomationStudio\\apps\\18.4.0>dir \"C:\\work\\appslocal\\logs\\log\\\" /O:D /B
2017.05.14.08.56.42.txt
2017.05.15.08.24.52.txt
2017.05.15.23.56.03.txt
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}