import re
regex = re.compile(r"(\d{4}\.\d{2}\.\d{2}\.\d{2}\.\d{2}\.\d{2}\.txt)$")
test_str = ("\n"
"C:\\BrowserAutomationStudio\\apps\\18.4.0>dir \"C:\\work\\appslocal\\logs\\log\\\" /O:D /B \n"
"2017.05.14.08.56.42.txt\n"
"2017.05.15.08.24.52.txt\n"
"2017.05.15.23.56.03.txt\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")