import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{4}\\.\\d{2}\\.\\d{2}\\.\\d{2}\\.\\d{2}\\.\\d{2}\\.txt)$";
final String string = "\n"
+ "C:\\BrowserAutomationStudio\\apps\\18.4.0>dir \"C:\\work\\appslocal\\logs\\log\\\" /O:D /B \n"
+ "2017.05.14.08.56.42.txt\n"
+ "2017.05.15.08.24.52.txt\n"
+ "2017.05.15.23.56.03.txt\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}