using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"```(.*)\s*([^]+?.*?[^]+?[^]+?)```";
string input = @"```markdown
## Hello
This is my new code:
`` <-- tutaj powinny być trzy "" ` "" ale psuje regex.
Tak powinna wyglądać grupa. Mój pomysł na rozwiązanie, to dodanie spacji przez trzema "" ` "".
Ale jak to zrobić w regex? :x
Czy da się to jeszcze lepiej zrobić, aby użytkownik mógł pisać kod z wykorzystaniem trzech ""`""?
``
```";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}