import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "```(.*)\\s*([^]+?.*?[^]+?[^]+?)```";
final String string = "```markdown\n\n"
+ "## Hello\n"
+ "This is my new code:\n"
+ " `` <-- tutaj powinny być trzy \" ` \" ale psuje regex.\n\n"
+ " Tak powinna wyglądać grupa. Mój pomysł na rozwiązanie, to dodanie spacji przez trzema \" ` \".\n"
+ " Ale jak to zrobić w regex? :x\n"
+ " Czy da się to jeszcze lepiej zrobić, aby użytkownik mógł pisać kod z wykorzystaniem trzech \"`\"?\n\n"
+ " ``\n\n\n"
+ "```";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}