import Foundation
let pattern = #"```(.*)\s*([^]+?.*?[^]+?[^]+?)```"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ###"""
```markdown
## Hello
This is my new code:
`` <-- tutaj powinny być trzy " ` " ale psuje regex.
Tak powinna wyglądać grupa. Mój pomysł na rozwiązanie, to dodanie spacji przez trzema " ` ".
Ale jak to zrobić w regex? :x
Czy da się to jeszcze lepiej zrobić, aby użytkownik mógł pisać kod z wykorzystaniem trzech "`"?
``
```
"""###
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)