# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"```(.*)\s*([^]+?.*?[^]+?[^]+?)```"
test_str = ("```markdown\n\n"
"## Hello\n"
"This is my new code:\n"
" `` <-- tutaj powinny być trzy \" ` \" ale psuje regex.\n\n"
" Tak powinna wyglądać grupa. Mój pomysł na rozwiązanie, to dodanie spacji przez trzema \" ` \".\n"
" Ale jak to zrobić w regex? :x\n"
" Czy da się to jeszcze lepiej zrobić, aby użytkownik mógł pisać kod z wykorzystaniem trzech \"`\"?\n\n"
" ``\n\n\n"
"```")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.