$re = '/```(.*)\s*([^]+?.*?[^]+?[^]+?)```/';
$str = '```markdown
## Hello
This is my new code:
`` <-- tutaj powinny być trzy " ` " ale psuje regex.
Tak powinna wyglądać grupa. Mój pomysł na rozwiązanie, to dodanie spacji przez trzema " ` ".
Ale jak to zrobić w regex? :x
Czy da się to jeszcze lepiej zrobić, aby użytkownik mógł pisać kod z wykorzystaniem trzech "`"?
``
```';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);