using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9A-Z][0-9A-Za-z,;:'""\* ]*[.!?;:]";
string input = @"This is an english sentence tokenizer; it tokenizes correct english sentences.
This can be done in a very short, ""regex"" string.
Incorrect sentence examples be like:
awesome thats so cool!
The text states, ""Super!"".
sys.exit()
(parenthesis)
New headlines!?!?!?
I want ice cream and/or pizza.
Correct sentence examples be like:
Awesome, that's so cool!
The text states, ""Super""!
0x000F;
S's's's's.
New headlines!
I want ice cream and or pizza.
I hate regex's ""catastrophic backtracking"" it's literally fake.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}