use strict;
my $str = 'This is an english sentence tokenizer; it tokenizes correct english sentences.
This can be done in a very short, "regex" string.
Incorrect sentence examples be like:
awesome thats so cool!
The text states, "Super!".
sys.exit()
(parenthesis)
New headlines!?!?!?
I want ice cream and/or pizza.
Correct sentence examples be like:
Awesome, that\'s so cool!
The text states, "Super"!
0x000F;
S\'s\'s\'s\'s.
New headlines!
I want ice cream and or pizza.
I hate regex\'s "catastrophic backtracking" it\'s literally fake.';
my $regex = qr/[0-9A-Z][0-9A-Za-z,;:'"\* ]*[.!?;:]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}