$re = '/[0-9A-Z][0-9A-Za-z,;:\'"\* ]*[.!?;:]/m';
$str = 'This is an english sentence tokenizer; it tokenizes correct english sentences.
This can be done in a very short, "regex" string.
Incorrect sentence examples be like:
awesome thats so cool!
The text states, "Super!".
sys.exit()
(parenthesis)
New headlines!?!?!?
I want ice cream and/or pizza.
Correct sentence examples be like:
Awesome, that\'s so cool!
The text states, "Super"!
0x000F;
S\'s\'s\'s\'s.
New headlines!
I want ice cream and or pizza.
I hate regex\'s "catastrophic backtracking" it\'s literally fake.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);