const regex = /[0-9A-Z][0-9A-Za-z,;:'"\* ]*[.!?;:]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9A-Z][0-9A-Za-z,;:\'"\\* ]*[.!?;:]', 'gm')
const str = `This is an english sentence tokenizer; it tokenizes correct english sentences.
This can be done in a very short, "regex" string.
Incorrect sentence examples be like:
awesome thats so cool!
The text states, "Super!".
sys.exit()
(parenthesis)
New headlines!?!?!?
I want ice cream and/or pizza.
Correct sentence examples be like:
Awesome, that's so cool!
The text states, "Super"!
0x000F;
S's's's's.
New headlines!
I want ice cream and or pizza.
I hate regex's "catastrophic backtracking" it's literally fake.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}