# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(src=\x22(https:\\/\\/[a-z]+.com\\/mp3s\\/[0-9]+\?id=[0-9]+)\x22)[\s\S]*/\2/gm;t' <<< "src=\"https://example.com/mp3s/2342344?id=24362456\"src=\"https://example.com/mp3s/2342344?id=24362456\"
src=\"https://example.com/mp3s/2342344?id=24362456\" src=\"https://example.com/mp3s/2342344?id=24362456\"src=\"https://example.com/mp3s/2342344?id=24362456\""