$re = '/^(src=\x22(https:\/\/[a-z]+.com\/mp3s\/[0-9]+\?id=[0-9]+)\x22)[\s\S]*/m';
$str = 'src="https://example.com/mp3s/2342344?id=24362456"src="https://example.com/mp3s/2342344?id=24362456"
src="https://example.com/mp3s/2342344?id=24362456" src="https://example.com/mp3s/2342344?id=24362456"src="https://example.com/mp3s/2342344?id=24362456"';
$subst = "\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;