import re
regex = re.compile(r"^(src=\x22(https:\/\/[a-z]+.com\/mp3s\/[0-9]+\?id=[0-9]+)\x22)[\s\S]*", flags=re.MULTILINE)
test_str = ("src=\"https://example.com/mp3s/2342344?id=24362456\"src=\"https://example.com/mp3s/2342344?id=24362456\"\n"
"src=\"https://example.com/mp3s/2342344?id=24362456\" src=\"https://example.com/mp3s/2342344?id=24362456\"src=\"https://example.com/mp3s/2342344?id=24362456\"")
subst = "\\2"
result = regex.sub(subst, test_str)
if result:
print(result)