import Foundation
let pattern = #"^(src=\x22(https:\/\/[a-z]+.com\/mp3s\/[0-9]+\?id=[0-9]+)\x22)[\s\S]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
src="https://example.com/mp3s/2342344?id=24362456"src="https://example.com/mp3s/2342344?id=24362456"
src="https://example.com/mp3s/2342344?id=24362456" src="https://example.com/mp3s/2342344?id=24362456"src="https://example.com/mp3s/2342344?id=24362456"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)