const regex = /^(src=\x22(https:\/\/[a-z]+.com\/mp3s\/[0-9]+\?id=[0-9]+)\x22)[\s\S]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(src=\\x22(https:\\\/\\\/[a-z]+.com\\\/mp3s\\\/[0-9]+\\?id=[0-9]+)\\x22)[\\s\\S]*', 'gm')
const str = `src="https://example.com/mp3s/2342344?id=24362456"src="https://example.com/mp3s/2342344?id=24362456"
src="https://example.com/mp3s/2342344?id=24362456" src="https://example.com/mp3s/2342344?id=24362456"src="https://example.com/mp3s/2342344?id=24362456"`;
const subst = `\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);