package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)object\/(custom|standard)\/(.*)(?:\/(typea|typeb))(?:\/(.*))?`)
var str = `Objects/Custom Objects/Applicant/Recruitment Pipeline/Buttons, Links, and Actions/Accept
object/custom/name1/name2
object/custom/name1/name2/typea
object/custom/name1/name2/typea/item
object/standard/name1/name2
object/standard/name1/name2/typeb
object/standard/name1/name2/typeb/item`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}