re = /object\/(custom|standard)\/(.*)(?:\/(typea|typeb))(?:\/(.*))?/m
str = 'Objects/Custom Objects/Applicant/Recruitment Pipeline/Buttons, Links, and Actions/Accept
object/custom/name1/name2
object/custom/name1/name2/typea
object/custom/name1/name2/typea/item
object/standard/name1/name2
object/standard/name1/name2/typeb
object/standard/name1/name2/typeb/item'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end