import re
regex = re.compile(r"object\/(custom|standard)\/(.*)(?:\/(typea|typeb))(?:\/(.*))?", flags=re.MULTILINE)
test_str = ("Objects/Custom Objects/Applicant/Recruitment Pipeline/Buttons, Links, and Actions/Accept\n\n"
"object/custom/name1/name2\n"
"object/custom/name1/name2/typea\n"
"object/custom/name1/name2/typea/item\n\n"
"object/standard/name1/name2\n"
"object/standard/name1/name2/typeb\n"
"object/standard/name1/name2/typeb/item")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")