const regex = /object\/(custom|standard)\/(.*)(?:\/(typea|typeb))(?:\/(.*))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('object\\\/(custom|standard)\\\/(.*)(?:\\\/(typea|typeb))(?:\\\/(.*))?', 'gm')
const str = `Objects/Custom Objects/Applicant/Recruitment Pipeline/Buttons, Links, and Actions/Accept
object/custom/name1/name2
object/custom/name1/name2/typea
object/custom/name1/name2/typea/item
object/standard/name1/name2
object/standard/name1/name2/typeb
object/standard/name1/name2/typeb/item`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}