import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\"complete\":false)|(\"success\":false))";
final String string = "{\"complete\":true,\"dateCompleted\":1533718801871,\"dateCreated\":1533718800064,\"detailedStatus\":null,\"executing\":false,\"failedOps\":0,\"failureReason\":null,\"opsCompleted\":11,\"opsExpected\":null,\"progress\":null,\"returnValue\":null,\"serverId\":\"lvt-guwccb-j013\",\"startDate\":1533718801613,\"starting\":false,\"startingOrExecuting\":false,\"success\":false,\"type\":\"ActivityEsc\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}