use strict;
my $str = '{"complete":true,"dateCompleted":1533718801871,"dateCreated":1533718800064,"detailedStatus":null,"executing":false,"failedOps":0,"failureReason":null,"opsCompleted":11,"opsExpected":null,"progress":null,"returnValue":null,"serverId":"lvt-guwccb-j013","startDate":1533718801613,"starting":false,"startingOrExecuting":false,"success":false,"type":"ActivityEsc"}';
my $regex = qr/(("complete":false)|("success":false))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}