const regex = /(("complete":false)|("success":false))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(("complete":false)|("success":false))', 'gm')
const str = `{"complete":true,"dateCompleted":1533718801871,"dateCreated":1533718800064,"detailedStatus":null,"executing":false,"failedOps":0,"failureReason":null,"opsCompleted":11,"opsExpected":null,"progress":null,"returnValue":null,"serverId":"lvt-guwccb-j013","startDate":1533718801613,"starting":false,"startingOrExecuting":false,"success":false,"type":"ActivityEsc"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}