# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/>([^*]*?)(<br|$)/<mark class=\'quote\'>$1<\/mark>$2/gm;t' <<< ">Some quote <br />
Some simple text<br />
<br>
> another quote with random <b>tags</b> and <a href=>links</a> in it"